Fee Promotions not reflected in Amazon Seller Central
Incident Report for Informed.co
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 31, 2019 - 10:03 EDT
Update
Fee Promotions have been disabled temporarily in Informed and will not be factored into price changes while Amazon works to resolve things on their end. In the meanwhile, Amazon is continuing to process refunds for all affected orders.
Posted 4 months ago. Jun 05, 2019 - 10:27 EDT
Monitoring
Amazon was able to identify an error in their system causing them to send out valid Fee Promotion data but not apply the discounted fees to orders. This issue has since been fixed on their end and we have been informed they will be issuing refunds on any orders where the fee promotion criteria was reached, but not applied.

We will continue to monitor while Amazon completes this process and post any updates here.
Posted 5 months ago. May 31, 2019 - 08:57 EDT
Investigating
We have received reports from some users that Fee Promotions are being applied to listings that are not reflected in Amazon Seller Central. We are currently investigating both internally and with Amazon and will continue to post any updates here.
Posted 5 months ago. May 29, 2019 - 11:44 EDT