Elevated load times
Incident Report for Informed Repricer
Resolved
We have confirmed this issue is resolved.
Posted Jun 22, 2020 - 15:52 EDT
Investigating
Some users have reported elevated load times, we are currently investigating.
Posted Jun 22, 2020 - 09:24 EDT